Peddle.com site outage
Incident Report for Peddle
Resolved
This incident has been resolved.
Posted May 26, 2023 - 15:18 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 26, 2023 - 14:32 CDT
Update
We are continuing to investigate this issue.
Posted May 26, 2023 - 10:32 CDT
Investigating
We are currently investigating an issue where peddle.com is inaccessible.
Posted May 26, 2023 - 10:24 CDT
This incident affected: Buyer Site, Carrier Site, Charity Site, Peddle Website, Publisher Site, and Seller Site.