Peddle website experiencing downtime
Incident Report for Peddle
Resolved
This incident has been resolved.
Posted Mar 13, 2023 - 13:31 CDT
Update
We have now stabilized. There are some ongoing issues with partnership page functionality (any link under peddle.com/partnerships).

We will post an update once these last issues are resolved, otherwise peddle.com should be fully usable.
Posted Mar 13, 2023 - 13:16 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 13, 2023 - 13:06 CDT
Update
We have identified the issue and are working to release a fix.
Posted Mar 13, 2023 - 13:02 CDT
Identified
Peddle.com is experiencing some downtime, all other services are unaffected.
We are currently investigating the issue.
Posted Mar 13, 2023 - 11:12 CDT