Vehicle photos intermittently failing to load

Incident Report for Peddle

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 13:57 CDT

Monitoring

We are aware of an issue causing vehicle photos across Peddle to load slowly or fail to load. This affects photo display on the buyer and seller sites, photos in email notifications, and photo uploads during carrier pickups.

The issue has been traced to an outage at a third-party image delivery provider, which is in turn caused by an ongoing Google Cloud incident. Peddle systems are otherwise operating normally, and no photos have been lost.

The vendor is actively working on resolution. We are monitoring closely and will post updates as we learn more.
Posted Sep 01, 2026 - 12:25 CDT
This incident affected: Buyer Site, Carrier Site, Seller Site, and Third party services.