Issues with Peddler Service
Incident Report for Peddle
Resolved
This incident was due to a caching issue and has been resolved.
Posted Sep 22, 2021 - 12:04 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 22, 2021 - 10:54 CDT
Investigating
We are currently investigating issues reported in the Peddler Service including issues with the user queues as well as access to Help Center articles.
Posted Sep 22, 2021 - 10:17 CDT
This incident affected: Peddle Website.