Peddle websites are down
Incident Report for Peddle
Resolved
This incident has been resolved.
Posted Sep 04, 2023 - 01:42 CDT
Investigating
We are currently investigating this issue.
Posted Sep 04, 2023 - 01:07 CDT
This incident affected: API, Peddle Website, Publisher Embed, and Seller Site.