Peddle services - partial outage

Incident Report for Peddle

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 16:50 CDT

Investigating

We are experiencing some outages with some critical services that are causing various functionality throughout our site to be impacted.
Posted Jul 14, 2025 - 14:01 CDT
This incident affected: API, Buyer Site, Charity Site, Peddler Site, Publisher Site, Publisher Embed, and Seller Site.